Back to overview
Downtime
DNS ns1.rootspirit.com, DNS ns1.rootspirit.nl, and 1 other service are down
Apr 20, 2026 at 7:11am UTC
Affected services
DNS ns1.rootspirit.com
DNS ns1.rootspirit.nl
DNS ns1.rootspirit.be
Resolved
Apr 20, 2026 at 7:32am UTC
DNS ns1.rootspirit.com recovered.
Affected services
Updated
Apr 20, 2026 at 7:28am UTC
DNS ns1.rootspirit.nl and DNS ns1.rootspirit.be recovered.
Affected services
Created
Apr 20, 2026 at 7:11am UTC
DNS ns1.rootspirit.com, DNS ns1.rootspirit.nl, and DNS ns1.rootspirit.be went down.
Affected services